[GPG 5 글 1.10] 루아 5.1.4에서 GPG5 루아를 게임에 통합-Harmon 오류 발생 질문

GPG 시리즈 관련 질답, 논의 공간.

Moderator: 류광

비회원

루아 5.1.4에서 GPG5 루아를 게임에 통합-Harmon 오류 발생 질문

Post by 비회원 »

lua_yield에 관한 작동 예제로 GPG5에 있는 소스를 참고하고 있었는데요,

근래에 이걸 최신 버전으로 교체하려고 5.1.4를 다운받아서 빌드한 다음 예제의 openlibs 부분 정도만 5.1에 맞게 바꾸고 5.1.4 라이브러리로 컴파일했습니다. 정적 링크를 선호해서 라이브러리를 static으로 만들어서 썼습니다.

헌데 일단 돌아가기는 돌아가는 것 같은데 메시지 없는 오류가 lua_yield를 호출할 때마다 발생되더군요.
뭔가 변한 점이 있어서 터지는 것 같은데... 이 문제를 해결하신 분은 없으신가요?